Controle de cache com PHP

Para nunca fazer cache de uma página

Para fazer cache de 1 hora (3600 segundos)

 

Data em portugues no php

Normalmente eu fazia alguns malabarismos, como um array com os nomes dos meses em português, mas a gente acaba esquecendo que o php tem função nativa pra praticamente tudo.

Pesquisando um pouco, descobri que é só trocar o locale que a mágica acontece =)

Referências:
http://br.php.net/strftime
http://br.php.net/setlocale
http://br.php.net/date_default_timezone_set

Imagem docker lemp/lnmp de fácil uso

Eu uso docker para ambiente de desenvolvimento, logo não preciso de tamanha complexidade com várias imagens dependentes montagem de diretórios cruzados etc.

Para esta finalidade basicamente preciso de um servidor lemp (ou lnmp), que é sigla para “Linux, (e)nginx, mysql e php” e um php myadmin.

Assim sendo criei uma imagem disponível publicamente no docker hub para quem precisa desta finalidade.

Para subir a aplicação com esta imagem, basta criar um docker-composer.yml na raiz de seu projeto com o conteúdo abaixo:

E depois rodar o comando:

A aplicação estará acessível em http://localhost/ e o PHPMyAdmin em http://localhost/pma/ simples assim.

Já está pré-configurado e com todos os grants necessários uma base de dados com o nome de “app” (sem as aspas) para uso na aplicação.

Como uso essa imagem nos meus projetos venho sempre aprimorando ela, então o changelog vai ficar sempre disponível em https://hub.docker.com/r/fbraz3/lnmp/

 

Instalar PHP5.3 no ubuntu 14.04

Esta dica teoricamente funciona também nas versões mais recentes do ubuntu.

Estes dias um antigo cliente meu entrou em contato solicitando a árdua tarefa de instalar o PHP  5.3 na última versão LTS do ubuntu (no momento em que escrevo é a 14.04).

Meu primeiro pensamento, foi baixar o tarball e compilar no servidor. Depois de mais de uma hora resolvendo dependências de bibliotecas, me deparo com erro na hora do make que eram basicamente questões relativas a versão de compilador, sendo praticamente impossível resolver (e olha que tentei).

Logo surgiu a ideia de buscar algum PPA que contenha esta versão, que também foi em vão, pois descobri que mesmo os repositórios que, em alguns artigos na internet diziam que continham esta versão do PHP, já haviam atualizado para as mais novas.

Quando tudo estava perdido, eis que surge uma ideia muito maluca. E se eu adicionasse os repositórios do ubuntu 12.04, deveria haver algum jeito de forçar o apt a utilizar pacotes de um determinado repositório.

Então, sem mais delongas, segue a receita de bolo:

Primeiro vamos criar um arquivo contendo os repositórios do ubuntu precise (12.04)

/etc/apt/sources.list.d/precise.list

Agora o “pulo do gato”, fazer com que os pacotes do PHP e do Apache utilizem este repositório

/etc/apt/preferences.d/php_precise

OBS: Os pacotes do apache são necessários caso você vá utilizar mod_php, se for utilizar php-fpm ou php-cgi, basta retirar os grupos referentes ao apache no arquivo acima.

Agora basta instalar os software e “voilà”

Todo esses procedimentos que citei (compilação, procura de ppa, testes), levaram horas do meu tempo livre, então se você estiver lendo isso e lhe for útil, um belo agradecimento seria um compartilhamento no facebook! 😉

Função para validar cartões de crédito com detecção automática da bandeira

Função para validar cartões de crédito, com suporte a validação de CVC.

O primeiro parâmetro é o número do cartão e o segundo o CVC (opcional), os dados serão sanitizados, sendo filtrado somente os números.

A saida é um array de três posições, a primeira retorna false (em caso de erro) ou a bandeira, a segunda se o número do cartão é válido e a terceira se o CVC é válido.

 

Ah, a minha esposa queria que eu botasse nesse post uma foto de gatinho, então lá vai:

Picture-86

Fonte: https://gist.github.com/erikhenrique/5931368

file_get_contents e scandir no php4

php
Pra quem precisa desenvolver mantendo compatibilidade com PHP4, aqui algumas funções que podem ser úteis. irei adicionando mais com o tempo.

E pra quem necessita de uma hospedagem de qualidade compatível com php4 ou várias versões do php5 (atualmente 5.2, 5.3 e 5.4), recomendo fortemente a kinghost.

 

Enviar email em html usando a função mail

Pra quem sempre se perde na hora de configurar os cabeçalhos:

Exemplo de uso:

solução para cackephp corrompendo cookies com suhosin

O cackephp por padrão criptografa o valor dos cookies para segurança só que isso causa incompatibilidades com o suhosin.

Uma possível solução é desativar o suhosin, porém isso poderia abrir uma grande brecha de segurança, então o mlehor a fazer é desabilitar a criptografia do cookie.

Para isto é só setar o terceiro parâmetro como false no método Cookie->write

Exemplo:

 

[magento] error parsing headers: duplicate header ‘Content-Type’

Um cliente usando api do magento em SOAP retornava o seguinte erro via php-fpm

[Thu Aug 02 17:50:57 2012] [error] [client xx.xxx.xxx.xxx] FastCGI: comm with server “/var/run/fastcgi/xxxx-fcgi” aborted: error parsing headers: duplicate header ‘Content-Type’

O erro com certeza estava na aplicação, seja em função de encoding ou por ser uma versão antiga do magento (1.4)

Resolvido erro inserindo a linha abaixo no arquivo app/code/core/Mage/Core/Controller/Response/Http.php